USACO 2015 February Contest, Silver
Cow Hopscotch ¹®Á¦ÀÔ´Ï´Ù.
Just like humans enjoy playing the game of Hopscotch, Farmer John's cows have invented a variant of the game for themselves to play. Being played by clumsy animals weighing nearly a ton, Cow Hopscotch almost always ends in disaster, but this has surprisingly not deterred the cows from attempting to play nearly every afternoon.
The game is played on an R by C grid (2 <= R <= 100, 2 <= C <= 100), where each square is labeled with an integer in the range 1..K (1 <= K <= R*C). Cows start in the top-left square and move to the bottom-right square by a sequence of jumps, where a jump is valid if and only if
1) You are jumping to a square labeled with a different integer than your current square,
2) The square that you are jumping to is at least one row below the current square that you are on, and
3) The square that you are jumping to is at least one column to the right of the current square that you are on.
Please help the cows compute the number of different possible sequences of valid jumps that will take them from the top-left square to the bottom-right square.
INPUT FORMAT: (file hopscotch.in)
The first line contains the integers R, C, and K. The next R lines will each contain C integers, each in the range 1..K.
OUTPUT FORMAT: (file hopscotch.out)
Output the number of different ways one can jump from the top-left square to the bottom-right square, mod 1000000007.
SAMPLE INPUT:
4 4 4
1 1 1 1
1 3 2 1
1 2 4 1
1 1 1 1
SAMPLE OUTPUT:
5
ÇÁ·Î±×·¥À» ´ÙÀ½°ú °°ÀÌ ÀÛ¼ºÇߴµ¥
#include <stdio.h>
#define MOD 1000000007
int r,c,k;
long long int a[101][101];
long long int d[101][101];
int mod(int x){
return (x+MOD)%MOD;
}
int main(){
scanf("%d%d%d",&r,&c,&k);
int i,j,l,m;
for(i=0;i<r;i++)
for(j=0;j<c;j++)
fscanf(inf,"%lld",&a[i][j]);
d[0][0] = 1;
for(i=0;i<r;i++){
for(j=0;j<c;j++){
for(l=i+1;l<r;l++){
for(m=j+1;m<c;m++){
if(a[i][j]!=a[l][m]) d[l][m] = mod(d[i][j]+d[l][m]);
}
}
}
}
printf("%lld",d[r-1][c-1]);
return 0;
}
4°³ test case¸¸ Á¤´äÀÌ Ãâ·ÂµÇ°í, ´Ù¸¥ test caseµéÀº Á¤´äÀÌ Ãâ·ÂµÇÁö ¾Ê½À´Ï´Ù.
Ç®ÀÌ¿¡¼µµ À§¿Í À¯»çÇÏ°Ô ÄÚµùÀÌ µÇ¾î Àִµ¥, ¹«¾ùÀÌ ¹®Á¦ÀÎÁö Àß ¸ð¸£°Ú½À´Ï´Ù.
Ç®ÀÌ
The grid is big enough that it is not possible for us to merely try all possible paths.
We simply care about how many ways there are to get to a given square though. Let f(x,y)
be the number of ways there are to get to row x
and column y
. Note that f(x,y)
is simply the sum of all f(i,j)
where i<x
, j<y
, and the numbers in those squares don't match. This gives us an O(R 2 C 2 )
algorithm, which is fast enough for our purposes.
°¨»çÇÕ´Ï´Ù.